9 고객지원‎ > ‎보안공지‎ > ‎

2010/02/19 국내 공개 웹 게시판(제로보드) 보안 업데이트 권고

게시자: 고영진, 2010. 2. 28. 오전 11:27   [ 2010. 2. 28. 오전 11:28에 업데이트됨 ]

□ 개요
 o 최근 국내 PHP 기반의 공개 웹 게시판 제로보드4에 대한 CSRF 관련 보안 취약점이 발견됨[3]
    ※ 제로보드(ZeroBoard): PHP 언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임워크
    ※ CSRF(Cross-Site Request Forgery) 취약점 : 정상적인 서비스 사용자의 권한을 몰래 이용하여
        스크립트를 실행할 수 있는 취약점으로 관리자 권한으로 악의적인 목적의 스크립트가 실행될 수
        있는 취약점
 o 해당 취약점을 이용한 홈페이지 변조 및 원격 실행 위협이 발생함에 따라, 사용자의 주의 및 조속한
    패치가 필요함

□ 영향
 o 원격의 사용자가 제로보드4 관리자 권한을 획득할 수 있음
 o 획득한 관리자 권한을 이용하여 시스템 내의 임의의 파일 읽기, PHP 명령실행 등이 가능하며,
    이를 이용한 웹 변조, 원격 실행 등이 발생할 수 있음
    ※ PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어

□ 영향 받는 시스템
 o 제로보드4 모든 버전

□ 설명
 o 원격의 사용자가 시스템 내의 임의의 파일을 읽거나, 임의의 php 코드를 실행하는 것이 가능하여 
    이를 통한 웹 변조 등의 해킹이 발생

□ 해결방안
 o 제로보드4를 처음 사용하는 경우
   - 공식사이트(www.zeroboard.com)에는 취약점이 보완된 admin_exec_member.php 설치 
      파일[1]을 다운로드 받아 설치

 o 제로보드4를 사용중인 경우
   - admin_exec_member.php 파일의 106번째 줄에 다음 아래와 같이 추가 


□ 이용자 주의사항
 o 09년 9월 25일부터 제로보드4는 구조적인 한계로 인한 보안 취약점 문제로 공식적인 배포를 중지함
 o 제로보드4의 공식적인 배포는 중지되었으나 신규취약점의 피해를 막고 정보를 공유하기 위해 공식
    커뮤니티는 계속 운영될 예정
 o 따라서 이용자들은 제로보드4의 공식 커뮤니티[2] 사이트의 보안 정보 공유 게시판[1]을 
    주기적으로 확인하여 신규 취약점에 대한 정보를 숙지하고 이에 따른 조치를 취해야함
 o 혹은, 지속적인 보안패치 제공 서비스가 가능한 홈페이지 게시판으로 업그레이드를 권고

□ 기타 문의사항
 o 제로보드4는 더 이상 사용할 수 없는 건가요?
   - 아닙니다. 사용하실 수 있습니다. 그러나 제작사에서 더 이상 공식적인 보안 패치를 제공하지 않기
     때문에 신규 취약점으로 인한 피해를 입으실 수 있으므로 이용자 주의사항을 숙지하시길 바랍니다.
 o 제로보드4의 공식 커뮤니티는 계속 운영되나요?
   - 네 운영됩니다. 제로보드4 공식 커뮤니티 사이트[2]는 제로보드4의 취약점 정보 및 기타 정보 
     공유를 목적으로 계속 운영이 됩니다.
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

[참고사이트]
[1] http://www.xpressengine.com/zb4_security
[2] http://www.xpressengine.com/zb4_main
[3] http://www.xpressengine.com/18695228

Comments